"Unknown Error. Contact your system administrator" when browsing to homepage


#1

After starting the Tomcat server and browsing to the URL I get an error message in the browser. The Tomcat log shows a number of similar error messages:

2016-10-05 15:36:42,153 ERROR [http-bio-7997-exec-6] co.gerger.bdf.view.BDFServlet: Unknown error
java.sql.SQLException: ORA-01422: exact fetch returns more than requested number of rows
ORA-06512: at “GITORA.BDF_SETUP_QRY”, line 9
ORA-06512: at “GITORA.BDF_SETUP_QRY”, line 81
ORA-06512: at “GITORA.BDF_ENGINE”, line 2054
ORA-06512: at “GITORA.BDF_ENGINE”, line 2264
ORA-06502: PL/SQL: numeric or value error: character string buffer too small
ORA-06512: at “GITORA.BDF_ENGINE”, line 2397
ORA-06512: at line 1


#2

Hi Stephan,

I guess you installed Gitora with manual installation scripts and you run some of the script files more than once.

What you can do to solve some this duplicate value issue is to open T_BDF_SETUP table of GITORA schema and delete duplicate records and try it again.

I hope this will be enough to solve this issue.

Kind Regards


#3

Hi Serdar,

I did use the manual scripts and ran into errors while executing 02_GITORA.sql so I ran the script again. There were several create statements with a “;/” that would only work when I removed the “;”.

In addition to T_BDF_SETUP I had to manually remove duplicate rows in T_BDF_SC_SETUP and ‘renamed’ the (duplicate) application in T_BDF_APPLICATION before the 03_GITORA.sql script worked.

I also noticed there is a grant missing on V$INSTANCE so the BDF_IDE_SETUP_V view could compile VALID.

One of our DBA’s commented that there could potentially be a problem with querying V_$SESSION in our (RAC) setup and mentioned it might be necessary to use GV_$SESSION instead. (I have no idea what that is about as I am not a DBA ;-))

Anyway, I got it working now and could create a new repository successfully.

I’ll post some more when I proceed with this tomorrow.

Thank you for your quick (and efficient) suggestion!


#4

Hi Stephan,

Thank you very much for the feedback. We truly appreciate it. We will go over the scripts and fix them.
There are many scripts to run which makes even preparing the scripts very error prone, so your feedback is very valuable. (The automatic installer takes care all of these issues but some environments require running scripts manually.)

As for RAC, I can’t remember exactly where and why we use the v_$session view. My educated guess is that not Gitora but the underlying framework Formspider is using this view. If my guess is correct, then you should be fine because Formspider works in production in RAC setups without any issues.

Nevertheless, if you run into issues let us know and we’ll take care of them. No worries.

Thank you for your interest in Gitora.

Kind Regards,
Yalim


#5

Hello Yalim,

I did some more testing of the manual installation today and found some more issues that I like to share with you:

01_SYS.sql is missing a grant execute on utl_http for GITORA. This makes the package body BDF_SC_HTTP invalid after running 02_GITORA.sql.

I noticed that in the final part of 02_GITORA.sql there is a recompile in a loop; I replaced that with EXEC DBMS_UTILITY.compile_schema(schema => ‘GITORA’); which takes a bit longer but finally leaves the schema entirely valid. (At first there were about 80 objects still invalid after running the 02_GITORA script.) A final small change I made (for ease of troubleshooting) is to put a spool 02_GITORA.log at the top of the script and a spool off at the end so I can search for any errors after execution of the script.

After all this, the 03_GITORA script executed fine and I got one error message from 04_SYS:

grant execute on api_gitora to public
*
ERROR at line 1:
ORA-01775: looping chain of synonyms

After all this I was able to start the application and load it successfully in the browser.

Kind regards,
Stephan.


#6

Hi Stephan,

Thank you so much for the feedback. We truly appreciate it.

I apologize for the errors. We tested the scripts countless times but there are so many moving parts in these scripts, it seems like we overlooked several issues.

We will update the scripts ASAP.

Kind Regards,
Yalim