Manual Ubuntu 16.04 Linux Server Installation - Error


#1

Hi,
I’am manually installed GitOra. Database installation was OK. (only exception at dbms_network_acl_admin package - because it not exist on 10g).
Tomcat start OK. But an error occured while accessing startpage.

2016-12-01 15:24:50,875 DEBUG [http-bio-7997-exec-1] co.gerger.bdf.view.BDFServlet: WebSessionId is
2016-12-01 15:24:50,876 INFO [http-bio-7997-exec-1] co.gerger.bdf.app.ApplicationState: Initializing new ApplicationState for session:
2016-12-01 15:24:51,325 INFO [http-bio-7997-exec-1] co.gerger.bdf.db.ConnectionWarden: Retrieving connection from explicit connection pool
2016-12-01 15:24:51,467 DEBUG [http-bio-7997-exec-1] co.gerger.bdf.db.ConnectionWarden: null - (Thu Dec 01 15:24:51 EET 2016)
2016-12-01 15:24:51,467 DEBUG [http-bio-7997-exec-1] co.gerger.bdf.view.BDFServlet: engineConnection: null
2016-12-01 15:24:51,478 ERROR [http-bio-7997-exec-1] co.gerger.bdf.view.BDFServlet: Unknown error
java.lang.NullPointerException: null
at co.gerger.bdf.view.BDFServlet.doPost(BDFServlet.java:191) ~[classes/:na]
at javax.servlet.http.HttpServlet.service(HttpServlet.java:650) [servlet-api.jar:na]
at javax.servlet.http.HttpServlet.service(HttpServlet.java:731) [servlet-api.jar:na]
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303) [catalina.jar:7.0.69]
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208) [catalina.jar:7.0.69]
at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52) [tomcat7-websocket.jar:7.0.69]
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241) [catalina.jar:7.0.69]
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208) [catalina.jar:7.0.69]
at co.gerger.filters.GZIPFilter.doFilter(GZIPFilter.java:55) [classes/:na]

  • i think the problem in database connection (there is no connections to GITORA schema in database session view ),
    but i am checked
    …/conf/context.xml" and
    …/webapps/gitora/WEB-INF/web.xml"
  • the connection string is present and correct.
    May you check the fix_parameters_LINUX.sh from maual installation ZIP?

#2

Hi Sergiu,

As you pointed it seems that Gitora couldn’t connect to database. Please try connecting with an database tool with the parameters from conf/context.xml just to be sure that you can connect to GITORA schema from your linux host. Some environments have firewall configuration that keeps Gitora establishing database connections.

On the other hand, the only duty of fix_parameters_LINUX.sh script file is to prepare configuration files like context.xml. If context.xml is correct then it means itworks as expected.

You can share web.xml and context.xml to let us see if there is anything looks odd.

Kind Regard
Serdar


#3

This is my web.xml and context.xml

https://drive.google.com/file/d/0B8APD_gCMlQFRkFTVVhPcnJVVmc/view?usp=sharing
https://drive.google.com/file/d/0B8APD_gCMlQFZjFfU0c3UUNteHM/view?usp=sharing

  • on my server i have not installed any tool to check database connection. But let me think a little about what can i install on server.

#4

Now I am checked connection to database from Gitora host - it is OK.

csadmin@CSVersion:~$
csadmin@CSVersion:~$
csadmin@CSVersion:~$
csadmin@CSVersion:~$ sqlplus64 GITORA/GITORA@//192.168.10.128:1521/XTEST

SQL*Plus: Release 10.2.0.5.0 - Production on Thu Dec 1 17:37:35 2016

Copyright © 1982, 2010, Oracle. All Rights Reserved.

Connected to:
Oracle Database 10g Enterprise Edition Release 10.2.0.1.0 - 64bit Production
With the Partitioning, OLAP and Data Mining options

SQL> select sysdate from dual;

SYSDATE

01-DEC-16

SQL>