HTTP access to the Version Control Server failed


#1

After creating a new repozitory I alway have this problem:
HTTP access to the Version Control Server failed, your changes cannot be saved to the Version Control Repository.
Can you help me with this?


#2

Hi Juraj,

Please check the baseURL from T_BDF_SC_SETUP table and compare it with the results of the folowing query which has to be run with SYS.

SELECT * FROM dba_network_acls

There has to be a line for baseURL here.

Best Regards.


#3

I check it and
T_BDF_SC_SETUP:
http://10.201.91.66:8080/gitora/

dba_network_acls:
1 10.201.91.66 8080 8080 /sys/acls/formspider_vc_GITORA.xml 161AE543894B8D15E0534F5018ACBA1A

so I think config is OK, but problem still occures


#4

Can you please check your database machine has right to access to this URL, http://10.201.91.66:8080/gitora/? You can check this by opening a browser in the computer that your database is installed, and open this URL.

Regards.


#5

I check it like this:
SELECT utl_http.request(url => ‘http://10.201.91.66:8080/gitora/’) FROM dual;
-this is not working.


#6

There might be a firewall rule which hinders connecting to this URL. Please try to connect this URL outside of DB.
e.g. you can use telnet, curl or wget if you’re in linux
or try it via browser if you’re in Windows

If you error occurs again, then you need to adjust your firewall rules.


#7

Yes through browser I can see the
"Welcome to Formspider!" webpage
I was looking to my firewall but there is no restriction I think i have to ask our system admins.


#8

Hello!

I am new to Gitora and I wanted to follow the steps presented here:

But I do get the same error(HTTP access…) when trying to create a new repository. I checked the baseURL from T_BDF_SC_SETUP and SELECT * FROM dba_network_acls, everything seems fine. The URL: http://10.201.91.66:8080/gitora/ I can’t access(This site can’t be reached).

Can you please tell me the solution to this problem? Or @zoffob how did you fix it? Thanks in advance!


#9

Hi Lavinia,

Did you run the Tomcat application server? Gitora has an application server that needs to be running. I believe it should be an icon on your desktop.

Kind Regards,
Yalim


#10

Thank you very much @yalimgerger for your quick response!

Yes, I did start Tomcat using the “Start Tomcat for Gitora” icon.
I use as default Schema, when trying to add a new Repository, the Gitora Schema Name created at installation (its Tablespace was SYSTEM if this matters).
Connecting to PLSQL Developer with that Username and the given password it’s done successfully.

With thanks,
Lavinia


#11

You are welcome Lavinia. I’ll ask you to wait until next week for a better answer from us.

Two more points even though I don’t think these are related to your problem:

  1. don’t pick the Gitora schema as the default.
  2. the next time you install Gitora, please don’t install it to the system tablespace.

We actually fixed this second issue in the upcoming new Gitora 2.0 installer.

Kind Regards,
Yalim


#12

Hello again!

I unistalled Gitora and install it again. I used this time USERS tablespace. Again, when trying to create a new repository I do get the same error, even if I use a different schema. When I click cancel and try to create the same repository I get an error which says that “The repository already exists”. But in the Repository list there is none and I cannot open it.

I don’t know what other options do I have, I would really like to solve this soon because I want to try and use Gitora.

Thank you,
Lavinia


#13

Hi Lavinia,

We need log files to find out your issue as it’s hard to reproduce it here locally. Can you please send us the log files under [Gitora Server Folder]\logs and [Gitora Server Folder]\apache-tomcat-xxx\logs folders?

Kind Regards
Serdar


#14

Thank you again!

I just sent the log files to this address: gitora {at} theformspider.com

Best regards,
Lavinia


#15

Is there any fix on this issue? I am running into the same thing where I can write to the repo with this error
"HTTP access to the Version Control Server failed, your chamges cannot be saved to the Version Control Repository."
Please help with this error. I am in dire need here.